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About the “Export FXL HTML” script
This script will export non-facing pages InDesign files to “fixed layout” HTML format. 
That is, HTML that retains the exact layout, typography, animation, and appearance from 
your InDesign layout. The resulting export is very similar to InDesign’s fixed layout EPUB 
export, but instead of producing a fixed layout EPUB, a folder of HTML, CSS, and Java-
Script is produced.

The folder will look similar to the folder shown at right. Each page of the InDesign file will 
export as a sequentially-numbered HTML file. The file without a number is the first page 
of the file, so this would be the “index” file, or the file you would want to open first with 
your browser.

The exported files can be posted to a Web server, or encapsulated into a mobile app using 
a service such as Adobe PhoneGap Build bit.ly/1OzcoPi. 

You can view sample output from 2 different InDesign files at bit.ly/2h234tJ and 
bit.ly/2h2aNYN. 

Do you like the idea of this script, but want more robust features? Then “in5” from Ajar 
Productions bit.ly/2g62XjB is for you! Like this script, in5 outputs HTML, CSS, and Java­
Script, but with single-file HTML output, many configurable options, smaller downloads, 
and support for facing pages documents.

Compatibility
This script will work with Macintosh and Windows InDesign CC 2014 and later.

Installation
Follow the steps below to copy the Export FXL HTML folder to the correct location:

1.	 Run InDesign

2.	 Display the Scripts panel on the screen (Window > Utilities > Scripts)

3.	 Right-click on the User folder in the panel, and choose Reveal in Finder (Mac) or Reveal 
in Explorer (Windows)

4.	 The folder that is highlighted in the Finder/Explorer is the folder you need to copy the 
Export FXL HTML folder into. 

5.	 Return to InDesign, and you should see the scripts appear in the User folder in the 
Scripts panel. You may need to flip the User folder closed and open once using the 
triangle to the left of the word “User”.

More information on how to install scripts can be found at adobe.ly/PgvxGB.

Watch a free Lynda.com video about how to install a script at bit.ly/2eLcHe2.

http://bit.ly/1OzcoPi
http://bit.ly/2h234tJ
http://bit.ly/2h2aNYN
http://bit.ly/2g62XjB
http://adobe.ly/PgvxGB
http://bit.ly/2eLcHe2
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File preparation checklist
There are a few limitations to keep in mind when using this script. Be sure to go through 
the checklist below to ensure that your file is constructed properly.

■■ The script only works properly with non-facing pages documents without spreads. If 
your document is set up with facing pages, choose File > Document Setup, and deselect 
the Facing Pages option.

■■ The script works on single InDesign files only. The Book panel is not supported.

■■ The document must not contain any objects that bleed off the edge of the page.

■■ Remove all items from the pasteboard before running the script.

■■ Text rotation in table cells is not preserved on export.

■■ Some transparent effects and blend modes are not preserved on export.

■■ Object Export Options that are specified for individual images are honored for file 
type, resolution, and image quality.

■■ Only OpenType and TrueType fonts will be embedded in the output. PostScript fonts 
will not be embedded, and will be substituted with other fonts when the output is 
viewed in a browser. It is your responsibility to determine if the fonts you have used can 
be legally embedded in HTML files.

Hyperlinks and page turning buttons
■■ Automatically-generated Table of Contents entries will automatically be hyperlinked 

to their corresponding pages if the “create text anchor in source document” option is 
selected in the Table of Contents options dialog box.

■■ Cross references and hyperlinks to text destinations are preserved on export.

■■ Buttons with the Next Page or Previous Page actions will not function in the exported files. 

■■ If you want to include clickable Next Page or Previous Page buttons on your pages, do 
the following:

1.	 Add some visible artwork such as right and left pointing arrows, to a master page so 
they appear on every document page.

2.	 Run the Add page buttons script. This script adds a new layer to your document named  
Page turn buttons, and places hyperlinked rectangles at the bottom-left and bottom-
right corners of each page that have the proper hyperlink setup that will function in 
the exported HTML files. These hyperlinked rectangles have no fill or stroke, so they 
can be moved into position as desired on top of the artwork you created in step 1.

Note: if you rename your InDesign file, add or remove pages, or change the page 
order, you will need to delete the Page turn buttons layer, and rerun the Add page but-
tons script.
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Page size recommendations
The script will output documents of any page size. The user will be able to use the zoom 
controls in their browser (usually command/ctrl+minus and command/ctrl+plus) to resize the 
page. However, to minimize file size and make the initial view fit reasonably well in most 
desktop browsers, your page width should be less than 1000px (approx. 14 inches) wide in 
InDesign.

The page will scale to fit the screen in mobile browsers. 

Running the script
1.	 If you don’t have the Scripts panel displayed on your screen, choose Window > Utilities > 

Scripts to display the Scripts panel.

2.	 In the Scripts panel, open the User folder, and double-click the Export FXL HTML script.

3.	 You will be prompted to choose a folder for the exported files. Create a folder, or 
choose an existing folder, and click Open.

4.	 Specify options for image compression, and click Export.

Customizing appearance and function with custom CSS or JavaScript
The Assets folder in the Export FXL HTML folder contains 2 files: myCustomCSS.css and 
myCustomJS.js. If you are familiar with CSS and JavaScript, you can customize these files to 
control the appearance and function of the output.

Disclaimer
This script is provided “as is”. Use at your own risk. No technical support for this script is 
provided.

I hope to see you at one of these excellent 
conferences in the future!

http://indesignconference.com
http://pepcon.com
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About Gilbert Consulting
Keith Gilbert is the principal of Gilbert Consulting, a St. Paul Minnesota consulting and 
training � rm. Keith has been instructing and consulting with graphic designers and 
communicators since 1985.

Keith is an Adobe Certi� ed Instructor, one of a select group of individuals nationwide to 
be certi� ed for on-site training in InDesign, InCopy, Illustrator, Photoshop, and Acrobat. 
Training and consulting engagements have taken him throughout North America, Asia, 
Africa, and Europe. 

Keith has a degree in Computer Science from the University of Minnesota. He is 
passionate about design and typography. When not teaching and consulting, Keith tackles 
design and production challenges for diverse clients. � is gives him a chance to use the 
latest so� ware to solve real world design and production problems.

Keith is a founding member and the Chapter Representative for the Twin Cities InDesign 
User Group. He is a lynda.com author, and a frequent speaker at industry seminars and 
conferences such as Adobe Max, � e InDesign Conference, and PePcon.

Clients include: 3M, AAF Central MN, AAF Duluth/Superior, Adobe, Advance Auto Parts, Agility Logistics, AgriBank, AGS, Alberta Weekly Newspapers Association, All Flex, 
Alphagraphics, American Express Financial Advisors, American Printing, Andersen Windows, Apple Computer, Association of Medical Illustrators, Augsburg College, Aveda, Automatic 
Equipment Mfg., Banner Engineering, Banta, Basin Electric Power Cooperative, Best Buy, Bethany Press, Billy Graham Evangelistic Association, BI Performance Services, Boelte-Hall, 
Boston Scienti� c, Bozell, Bolger, Boom Island, Bras� eld & Gorrie, Britton MDG, Bureau of Indian A� airs, c3 Premedia, Callan Publishing, Capstone Press, Caribbean Development 
Bank, Carleton College, Calumet Photographic, Cargill, Carmichael Lynch, Carlson Marketing, Century Graphics, Cenveo, Cities of Burnsville, Eagan, Edina, Golden Valley, Plymouth, 
South St. Paul and Woodbury, City and Regional Magazine Assoc., Clarity Coverdale Fury, Coleman Brandworx, Colle+McVoy, College of St. Catherine, Color Response, CompCare 
Publishers, Coughlan Publishing, Country Insurance, Creatis, CreativePro, Cybex, Data Recognition Corporation, DBI-SALA, DecoPac, Deluxe, Det-tronics, Digi-Key, DPD Print 
Management, DowBrands, ECM Publishers, Ecolab, EFI, EIS Digital Publishing, Ellerbe Becket, Ellett Brothers, EMC, Emerson, Experience Life magazine, Explore Minnesota Tourism, 
FAF Advisors, Fairview Health Services, Fallon, Franke + Fiorella, Free Spirit Publishing, Gabriel deGrood Bendt, GAGE, Gausman & Moore, General Electric, General Mills, Gopher 
Sport, Gradient, Graf Advertising, GraphicsXpress, Gray Plant Mooty, Great Northern, Greenspring Media Group, Group Design, Hamline University, Hazelden, HealthPartners, Hendlin 
Visual Communications, HGA, Holmberg, Home Service Publications, Hormel Foods, IFAI, IFG Asset Management, IKON O�  ce Solutions, Illume Candles, InDesign Magazine, Insignia 
Systems, Jostens, J.W. Hulme, Kids Quest, KMSP Television, K.L. Publications, Lafayette Litho, Lakewood Publications, Lands’ End, Larsen, Laser Systems, Lawrence University, Lifetouch, 
Litho Inc., Little & Co., � e Liturgical Press, Lockheed Martin, Lumonics, Machine Tool Supply, Macalester College, Macy’s, Malt-o-Meal, Mammoth Marketing Communications, 
Market Motif, Martin Williams, Maurices, Mayo Clinic, MCS, Media II, Media Trust, Medical Arts Press, Medtronic, Merrill, Metro Printing, Metro Transit, Meyers Printing, MHS Press, 
Midwest Energy Association, MIIAB, Minneapolis College of Art & Design, Minneapolis Institute of Art, Minneapolis Public Library, MN Association of Government Communicators, 
MN Association of Realtors, MN CLE, MN Dept. of Administration, MN Dept. of Children, Families & Learning, MN Dept. of Human Services, MN Dept. of Natural Resources, MN 
Dept. of Public Safety, MN Dept. of Revenue, MN Dept. of Trade & Economic Development, MN Medical Research Foundation, MN Secretary of State o�  ce, Mobium, Mortenson, MSP 
Communications, National Association of Government Communicators, National Computer Systems, National Gallery of Art, NEEP, North American Membership Group, Northrup 
King, Norwest, OptumInsight, Oracle, Organic Valley, Parachute Design, Paulson Marketing, Pearson, Periscope, Phipps Creative Services, Preventive Care, Prime � erapeutics, Printing 
Industries of Minnesota, Prisma, Prosthetic Laboratories, Prudential Insurance, Purup Prepress America, Quebecor World, R&D Systems, Ramsey County, Rockler, RCP Strategic 
Services, RR Donnelley, Sage Company, San Diego Union-Tribune, Sandoz Nutrition, Science Museum of MN, Scienti� c Societies, Scoville Press, SEH, Segal Savad, Sells Printing, 
Sibley Medical, SIT Investments, Slumberland, Smead, Smiths Medical, Smithsonion Institution, Spectrum, South Central College, South Dakota Education Association, Southern 
Graphics, St. Cloud State University, St. John’s University, Starkey, Stanton Publication Services, StoneL, Sterling Sommer Creative Printing, Sun Newspapers, Tad Ware & Company, 
Taylor, Target Corp., TargetCom, Technicon, Tescom, � omson Reuters, � rivent, Tiger Oak, Trade Mark Specialty, TREND Enterprises, Tweak.com, Ulteig Engineers, United Nations, 
United Properties, University of Minnesota, University of Wisconsin Eau Claire, Upsher-Smith Laboratories, U.S. Bank, Utne Magazine, UV Color, Valley Dental Arts, Vera Bradley, 
Vertis, Viking Press, Wacker Chemical, Walman Optical, Web Label, Webster University, Welsh, Westwood Professional Services, Wilson’s, Worzalla, Yamamoto Moss MacKenzie
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